You signed in with another tab or window. Reload to refresh your session.You signed out in another tab or window. Reload to refresh your session.You switched accounts on another tab or window. Reload to refresh your session.Dismiss alert
{{ message }}
Repository navigation
unplugin-vue-i18n: bump @intlify/vue-i18n-extensions to ^9 to drop the deprecated vue-i18n@10 #674
@intlify/unplugin-vue-i18n 11.2.7 (latest) depends on @intlify/vue-i18n-extensions ^8.0.0, and vue-i18n-extensions 8.0.0 has a hard dependency on vue-i18n ^10.0.0. Every project on vue-i18n 11 (for example through @nuxtjs/i18n 10.x) therefore installs a second, unsupported copy of vue-i18n and gets this on every install:
npm warn deprecated vue-i18n@10.0.8: v9 and v10 no longer supported. please migrate to v11.
@intlify/vue-i18n-extensions 9.0.0 fixes it: it moves vue-i18n and @intlify/shared to optional peer dependencies (^9 || ^10 || ^11), and its published dist is byte-identical to 8.0.0 apart from package.json (engines node >= 22). We checked this by diffing the two tarballs, and by installing 9.0.0 through an npm overrides: the build and our tests pass and the duplicate vue-i18n is gone.
The update is already pending in the Dependency Dashboard (#304, renovate/v11-intlify-vue-i18n-extensions-9.x). Could it be approved and released in a patch of @intlify/unplugin-vue-i18n 11?
Activity
kazupon commentedon Oct 27, 2026
I've just fixed at v11.2.8
Please check it!