Repository navigation
Upgrade esp-hal to 1.2.x - #110
Conversation
|
Hi, keen for this, but now that I enabled the CI builds, can you look into the CI build errors and resolve these? Thanks! |
|
@ahdinosaur the CI is passing now |
ahdinosaur
left a comment
There was a problem hiding this comment.
Needs a search and replace for anywhere that mentions the existing msrv (minimum supported rust version) 1.88.0, to be updated to 1.95.0.
Thanks!
| if: matrix.device.toolchain == 'esp' | ||
| with: | ||
| version: 1.88.0.0 | ||
| version: 1.95.0.0 |
There was a problem hiding this comment.
Hi, you missed another one of these in .github/workflows/release.yml:
https://github.com/search?q=repo%3Aahdinosaur%2Fblinksy+1.88.0.0&type=code
There was a problem hiding this comment.
Here too. Also Cargo.toml and esp/Cargo.toml:
https://github.com/search?q=repo%3Aahdinosaur%2Fblinksy+1.88.0&type=code
There was a problem hiding this comment.
At first I was thinking we would leave the main crate at 1.88 because it's strictly only the esp stuff that needs 1.95 but I guess it makes sense to upgrade everywhere for simplicity.
There was a problem hiding this comment.
Ah yeah that's fair enough. I could be convinced either way, but generally I'd rather have one version to install and think about. Thanks for the update!
|
@ahdinosaur could you please take another look? Thanks! |
|
Thanks @mlandauer ! |
No description provided.